Instalación de Autoroute 2011 en Windows 7 64 bits

Éste es un programa de los que se ponen tontos, muy tontos, para instalarse. No sé si es de una división de Microsoft que no se habla con el resto de los compañeros de Redmond, pero el caso es que instalarlo (y hacerlo funcionar) es una auténtica odisea. Voy a ir por partes.

Instalación:

El programa no se instalará si tienes instalado el Service Pack 1 de las rutinas Visual C++ 2008. Esto es así porque los prerrequisitos de la instalación incluyen (entre otros) las rutinas de VC++ 2008 y al fallar la instalación (por encontrarse una versión más reciente instalada), la instalación del producto falla.

Solución: Ejecutar directamente el fichero \AutoRte\MSMap\data.msi que se encuentra en los ficheros de instalación.

Durante la instalación, además, a mí me devolvió el siguiente error al “publicar el produto”:

    Error: A Licensing initialization error has occurred, 0x80070005

 

No había manera de resolverlo pero, ignorándolo, la instalación terminaba con éxito.

Ejecución:

Al arrancar el programa, el error de licencias volvía a aparecer, pero no seguía cargando como en la instalación.

Solución: La primera vez que se arranque el programa hay que hacerlo como Administrador. Así se consiguen los permisos necesarios para el acceso al Registro que necesita la aplicación para publicarse con éxito.

Tras solucionar el error de licencias, aparecía la pantalla de carga de la aplicación, y ahí permanecía, consumiendo el 100% de CPU y sin recuperarse, hasta matar el proceso.

Solución: Existe un artículo de la base de conocimiento de Microsoft (http://support.microsoft.com/kb/2618410) en el que se explica que la causa del problema es la interacción del Service Pack 1 de Windows 7 con Autoroute y que hay un parche en camino, pero obviamente no le voy a recomendar a nadie que desinstale un Service Pack de Windows. El procedimiento para identificar el programa que bajo Win7 SP1 causa el problema, tal y como se indica en el artículo, es analizar qué servicios y drivers podrían estar interfiriendo con Autoroute. Voy a dar unas cuantas pistas, por lo leído en Internet y por mi propia experiencia. Probar a desactivar los siguientes programas, drivers y servicios:

 

  1. Lectores de huellas dactilares
  2. Drivers propietarios de pantalla táctil
  3. Servicio de entrada de Tablet PC
  4. Drivers de productos de Wacom
  5. Programas residentes que tengan filter drivers adjuntos a la pantalla, como los que graban o captura el escritorio.

 

En mi caso era un programa del tipo 5, Xfire, que permite obtener capturas de pantalla y vídeos del escritorio y de aplicaciones DirectX. Para descubrirlo, usé Process Explorer (http://live.sysinternals.com/procexp.exe) y observé que en uno de los hilos de AutoRout.exe aparecía xfire_toucan.dll. Al salir de Xfire, Autoroute arrancaba (por fin).

 

“Sorcerers of madness
Selling me their time
Child of god sitting in the sun
Giving peace of mind”

 

(Black Sabbath – Spiral Architect)

 

 

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s